YNAB & Linux | YNAB

YNAB & Linux

When YNAB 3 first launched, we advertised it as being compatible with Windows and Mac. Soon after we launched, we got a lot of enthusiastic reports from users telling us that YNAB was working great on their Linux machines as well. We use the Adobe AIR platform for YNAB, and were thrilled to hear it was working flawlessly for Linux customers! By popular demand, we began advertising that YNAB was Linux compatible as well.

That worked quite well for us for quite a while, but recently things have begun to change. As we've grown in popularity, we have increasingly found ourselves troubleshooting obscure install issues for Adobe AIR on various Linux flavors, many of which we were not familiar with. If a Linux customer had a problem, it took us ten times as long to provide the same incredible level of support that we could for Mac or Windows. Furthermore, our Linux customers were, as a percentage, having more problems getting AIR installed correctly. To paraphrase a recent potential customer who was having trouble getting AIR working: "If you advertise Linux compatibility, I expect it to be easy." He's right! We only want to advertise YNAB for platforms that we can enthusiastically proclaim, "This will work great for you! We promise! If it doesn't, we'll work until it does." The fact is, we can't do that for Linux anymore.

On top of that, Adobe no longer officially supports AIR on Linux, and we don't want to make implicit guarantees about future compatibility with YNAB 4, 5, 6, etc. So, even though YNAB will probably work on your flavor of Linux (perhaps with a bit of Googling and some command-line know-how), we can't guarantee it, and are no longer advertising YNAB as "Linux compatible." If you're the persistent sort, please feel free to install an older version of AIR and then give YNAB a shot!